Start a new topic

Device token is empty?


I'm trying to create a new user, and it succeeds (at least it shows up in the console) but I also get an error: Kinvey Ertror Code = 406, "Device token is empty".

Can someone please explain what that means?



1 person has this question

Hi Michael,

Have you setup Android/iOS push certificates for this Kinvey App? Can you share a screenshot of the console and the app id (kid_xxxx)?




I have the same error when I try to log in


Hi, Aniruddha:

I've done nothing with push certificates ... I didn't think that I had to in order to just let a user be created. The app id is kid_bky5mXtV6g.

Thanks for looking into this.

(96 KB)

Hello MP Rogers,

At present we've pushed out an update to our iOS library (1.40.4) which we believe should address this issue.  If this issue persists, can you please contact me on here and attempt to provide me with some code to reproduce the issue, as we're struggling to do so internally at the moment.

The library is available here:


Yup, that has solved the problem nicely. Thanks for doing this so expeditiously. [On a side note, I'd been using Parse for the basis of a workshop next month, and discovered to my horror a few days ago that Parse was shutting down and wasn't allowing new users to connect. I was able to port most of it pretty quickly to Kinvey, and I'm looking forward to telling all my participants about the features and quick response from the developers!].


Did the same...  changing from Parse to your product..  have to reprogram the whole app.

had also the same problem with 1.40.3

update of the pod did the trick..  is working now

Wonderful,  I'm glad to hear that we're getting a lot of people coming over from Parse, and that we were able to get this fixed so quickly for you guys. 

If you have any other questions or concerns, please let me know.  


Login or Signup to post a comment