Start a new topic

Titanium 3.X SDK


I've just started a new Appcelerator Titanium project and I'm trying to add Kinvey SDK to it. 

However, the app throws an error at start and the only thing that I have in my app is the SDK. No extra code, nothing. And I've even removed the "init" method. Only the require() remained. 

I've tried with different versions, for example:

v3.0.0-beta17 throws:

[ERROR] : Script Error {

[ERROR] : column = 134;

[ERROR] : line = 4532;

[ERROR] : message = "Can't find variable: Symbol";

v3.1.0 throws:

[ERROR] : Script Error {

[ERROR] : column = 168;

[ERROR] : line = 23768;

[ERROR] : message = "Super expression must either be null or a function, not undefined";

I've even tried with different versions of Titanium SDK, 5.4, 5.3, 5.1, etc


any news on this? :) Since it's wednesday, i guess there are still problems?

Best, Nico

Hello Nico,

Our regrets, but this fix has pushed out until October 1, 2016. The engineer is finishing up the solution and we need some additional time to test due to the complexity.

We will update you once the release is available. Please let us know if you have any questions.


Billy Gee


i saw there was an update on the Titanium github Project - is this already the official "new" Release for the Titanium Kinvey SDK ?

2 Notes:
- After login a user and restart the app, the "activeuser" is always null. Is this the correct behavier?
- Setting the Log-Level (like documented) isn't possible and results in an error that the function is undefined. 

Best, Nico

Hello Everyone,

For those of you who do not already know, the Titanium SDK v3.2.1 has been released and can be found at the following URL for download.

3.2.1 - Oct 6, 2016

Enhancement: Added the ability to do interactive push notifications.

Enhancement: Default apiHostname protocol to https: if one is not provided.

Bugfix: Fix push notifications.

Bugfix: Prevent delta fetch from loading all entities when they are not needed.


Billy Gee

Login or Signup to post a comment