Start a new topic

Titanium 3.X SDK

Hello,


I've just started a new Appcelerator Titanium project and I'm trying to add Kinvey SDK to it. 


However, the app throws an error at start and the only thing that I have in my app is the SDK. No extra code, nothing. And I've even removed the "init" method. Only the require() remained. 


I've tried with different versions, for example:


v3.0.0-beta17 throws:

[ERROR] : Script Error {

[ERROR] : column = 134;

[ERROR] : line = 4532;

[ERROR] : message = "Can't find variable: Symbol";


v3.1.0 throws:

[ERROR] : Script Error {

[ERROR] : column = 168;

[ERROR] : line = 23768;

[ERROR] : message = "Super expression must either be null or a function, not undefined";


I've even tried with different versions of Titanium SDK, 5.4, 5.3, 5.1, etc


Hello Mihai,


Thank you for the quick reply. We will let you know when we have a target date and/or update available.


Regards,


Billy

Hello Mihai and Everyone,


We appreciate your patience as we try to resolve this problem. I just spoke with Engineering and they are going to have to delay this update. The problem turned out to be more complicated than originally thought and we had to engage the Appcelerator team to assist with a Titanium bug.


The revised target date for a new update is Tuesday of next week, September, 27, 2016, Eastern Time. We will try to release it sooner if at all possible.


Please let us know if anyone has any questions.


Regards,


Billy Gee


Thanks. 


More info :

Appcelerator Command-Line Interface, version 5.5.0

Operating System

  Name                        = Mac OS X

  Version                     = 10.11.6

  Architecture                = 64bit

  # CPUs                      = 8

  Memory                      = 17179869184

Node.js

  Node.js Version             = 5.11.1

  npm Version                 = 3.9.0

Titanium CLI

  CLI Version                 = 5.0.9

Titanium SDK

  SDK Version                 = 5.5.0.GA

Alloy 1.9.2

Xcode 8 (just installed, 7 was not working either)





Hey,


thanks for the update! :) 

Login or Signup to post a comment