Start a new topic

Problems deleting files

I have problems deleting files from my Application.  And I don't get any reason.

I delete two files, both exist, I can show both images: 

first with id xxx_XX_XXX: call delete (through Java SDK and via Rest), Result: everything works fine, image deleted, metadata deleted

second with id xxx: call delete, Result: image deleted, metadata not deleted, error from the system: Blob not found

now I have files without a blob inside my application which I can not delete because I always get the error "Blob not found"

Can you please help me with this problem?

Hi Leif,

As file upload to Kinvey is a two step process, it might be possible that you uploaded the metadata but didn't finish the file content upload.

Have you tried to delete this file manually using Kinvey Console?



Kinvey Support


as I wrote in my first message both files are uploaded and accessable before I try to delete them.

I tried to delete them via the Kinvey WebUI: nothing happens. When I refresh the item is still there.



Login or Signup to post a comment