Start a new topic

kinvey PCL package will not install in Xamarin / Could not load assembly PubNub-Messaging

After creating a new Xamarin PCL app, the core PCL project will not allow the Kinvey NuGet package to be installed. Here is the error message.

image


Here is my project PCL setup.

image


Here is the setup of the PCL in the KXStarterApp (identical to mine)

image


They are identical. The only difference that I see between the sample app and mine is that the sample app uses xaml ui and I am using C# ui. Why can I not get the package to install?


UPDATE


I was able to resolve this by downloading and installing the xamarin package .dll's directly from here (http://devcenter.kinvey.com/xamarin/downloads). Now I am stuck on this error. 


/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Exception while loading assemblies: System.IO.FileNotFoundException: Could not load assembly 'PubNub-Messaging, Version=1.0.6201.20023, Culture=neutral, PublicKeyToken=dc66f52ce6619f44'. Perhaps it doesn't exist in the Mono for Android profile?


2 people have this question

Hello Sevren,


I am glad to hear you were able to make it work.


I will share this information with our Engineering team so that they will know that updating an existing project has issues but starting from scratch works OK. 


Regards,


Billy Gee

I was able to get this working by starting with a fresh project. For the time being, it is working!

Hello Billy. After trying both the nugget package and the .dll packages I get the exact same errors. There has been no change. 

Hi Billy, I will give this a go. In the meantime maybe you can help me with another blocking breakage that is keeping me from using kinvey. The was happening with v3.0.8 as well. This packaging error happens no matter what Profile I choose in the PCL options.


image


Hello Sevren,


A new version of the Xamarin SDK v3.0.9 is available for release at the following URL.


http://devcenter.kinvey.com/xamarin/downloads


It fixes the problem that you described in this ticket relating to a package installation problem.


Please download at test the solution at your convenience and let us know if the problem is fixed to your satisfaction.


Regards,


Billy Gee

Sevren,

Thanks for providing this information. I have updated engineering escalation with SDK information. Will keep you posted on the progress.

Thanks,
Pranav

Kinvey

Yes, all projects are using 3.0.8.

Hello Sevren,


Can you please confirm which version of the Xamarin SDK you are using. I assume it is 3.0.8 but I want to be 100% certain because I have just escalated this problem to Engineering to investigate.


Regards,


Billy Gee

Kinvey Support


MLIBZ-1876

Hello Sevren,


Thank you for posting the update. We are looking into this and will get back with you as soon as we know more or have a solution.


Regards,


Billy Gee

Kinvey Support

Login or Signup to post a comment