Start a new topic

kinvey-bl deploy results in 500 error code response

So I ran `kinvey-bl init -e <my_email> --app <my_app> --environment <app_env_name> --host`
It downloaded everything correctly.
To check how it'll deploy I ran `kinvey-bl deploy` with all the same parameters, response:
> Sending scripts to Kinvey. This could take a moment...

> Status Code: 500 Message: An unknown error has occurred.

> There was an error while sending the request to Kinvey. Please try again or check out our support forums ( for more help.

`kinvey-bl deploy` without parameters yields the same.

Hi Ilia,

We have reviewed the server logs for the reported error code to the described host and found the reason for the failing requests. It seems that with the business logic deployment you are trying to remove an existing business logic endpoint and this is causing some unexpected behavior and thus returning an error. We have identified the issue and a fix is expected in about a day.

I will notify you additionally when the fix is ready.



Hi Ilia,

The issue has been fixed. 

Could you please try and confirm if it is working on your side?



Login or Signup to post a comment