Start a new topic

Scheduled Code

I have 2 custom endpoints. Both of which work fine when i test them using 'Send Request'.  When i set these endpoints to the 5 minute interval in scheduled code, nothing happens.  The code does not run and none of the logs display in the 'logs window' at the bottom.  These endpoints used to work just fine as scheduled code the last time i tested, apx 4~ weeks ago.  I did not test the other interval lengths as they are not relevant to the project, the 5 minute interval is the only acceptable option you offer.


Thank you for reporting this problem. We are already aware of it and are investigating. FYI, there is a new release of the scheduler due this month and it might get released before we are able to get to the bottom of this problem.

Can you give me the name of those 2 endpoints that you have scheduled to execute?

If it is possible, please try reconfiguring your custom endpoints to the 5 minute interval and let me know if it works fine.



Hello Matt,

We have released an update to the scheduler that should fix your problem with scheduled code. Can you please try again and let us know if this update fixes the problem to your satisfaction or not?

We look forward to hearing back from you.


Billy Gee

hey Billy,

I had a chance to check out the business logic and i'm happy to report that seems to be working fine now.  However, I have a custom endpoint which accesses twilio and creates a new phone number from a list of available numbers.  This custom endpoint was working last week and now is no longer working (bad request).  Do you have any info why this might be happening?  I've been attempting to debug this issue both in the kinvey and twilio dashboards with no luck so far



Hi Matt,

Martin here, stepping in for my colleague Billy. I have reviewed the server logs and can see a lot of 500 errors (BLTimeoutError - The Business Logic script did not complete. Please contact support","debug":"The execution of a background task timed out.).

The errors are for the custom endpoints sendEmailMessage and sendReminders.

Are these the custom endpoints you are referring to? If so could you please review/test the endpoints as it seems that they do not finish in the 2 seconds execution time limit.

If the endpoint is different, could you please specify the KID and the custom endpoint name?


Martin Apostolov

Login or Signup to post a comment