Start a new topic

iOS Frameworks Bitcode Issue

Ok so I am using the drag and drop method to import the frameworks into my projects.  I have tried using version 3.14 but  continue to get the error


Failed to verify bitcode in KeychainAccess.framework/KeychainAccess:

error: Cannot extract bundle from /var/folders/xk/czct3p6j1fg74_08n6tvt4hh0000gn/T/XcodeDistPipeline.TA7/Root/Payload/'ProjectName'/Frameworks/KeychainAccess.framework/KeychainAccess (i386)


Project Name is being used in place of the real project name.


I have tried updating to the most recent version 3.18, but instead get a different issue when I try to run it on my ipad xcode gives me the message


This application’s bundle identifier does not match its code signing identifier.  So while it does work in the simulator I am not able to distribute my app.  


I have tried cleaning and building, deleting the frameworks and reincluding, and various types of build settings.  


I would prefer not to use pods so does anyone know a solution to this problem?



Ming,


Does the error go away after removing Kinvey framework from your project?


Thanks,

Pranav

Kinvey

I believe so, but I do need to use kinvey to make my project function.  The thing is I am able to create an ipa with 3.14 but only if I disable rebuild from bitcode.  Still in 3.18 it will give the aforementioned error when I try to directly install it to my ipad from xcode.  

Ming, 


I am not able to reproduce this issue. Please set Enable Bitcode to 'NO' in Build Settings and retry. 

Also, may I ask you why you don't prefer using Pods?


Thanks,

Pranav

Kinvey

Enabling bitcode to NO creates an IPA that does not install, but disabling rebuild from bitcode from the archive creates a functioning ipa.  Also I just have an issue using the console to install the pods I find it causes more problems.  Also did you try to recreate the issue by manually putting in all the frameworks from 3.18 and 3.14 instead of using pods?.  


In addition I tried the same thing with a blank project and framework 3.18 and found that installing directly to device I get the message 


This application’s bundle identifier does not match its code signing identifier.


When I create an IPA with and without bitcode it fails to install, but the blank project works fine when I take the frameworks out.  So it seems the issue comes from directly adding the frameworks so I would please appriciate some assistance on this matter.  



Thank you and I look forward to your response.  

I have switched over to cocoa pods and the ipa generation seems to work, but I would still like to know what is going on with the regular frameworks.  

Hello Ming,


Glad to hear that you are able to move past the issue by using pods. I am not sure about the problem that you are facing with the regular frameworks as I am not able to reproduce the issue on my side.


Thanks,

Pranav

Login or Signup to post a comment