Start a new topic

Import data not working

hello there, i want to import data from csv file. when i import the csv file, it says data imported successfully but no data is shown in the collection. i think it is a bug. please help me with this issue.


Pratap,


Your reply to this ticket opened a new support ticket. I have closed that and will continue assisting you on this forum post. Copying your comment here to complete the loop:


"pranav, I tried your suggestions but none of them working. same issues on fresh new collection. check my csv file."


Thanks,

Pranav

Kinvey

csv
(685 Bytes)

Hello Pratap,


I tried importing a CSV file and I can see all the data in the collection. Would it be possible to provide me with the CSV file for which you are facing issues?


If not, please confirm the following things on your side:

  1. Let me know which columns are used in the CSV file.
  2. Go to the collection for which you are trying to import a CSV file, click on the button next to the "Add  Row" button and confirm if "Column visibility and sorting" is set to  "Show All". You can also try 'Reset Column Preferences' option and let me know if it solves your issue.
  3. Which browser are you using? Check 'Network' tab of Browser Developer Tools on your browser and see if it shows any useful information while importing the CSV file.
  4. Create a fresh new collection and try importing the CSV file in that. Let me know if you see the same issue there.



Thanks,

Pranav

Kinvey



Pratap,


I am able to see the same issue. I think the problem is with "_geoloc" column in the CSV. If you remove it from the CSV and try importing again, all the data is getting imported correctly. If you convert the CSV to a JSON file and try importing it, all the data is getting imported successfully (including "_geoloc" column). I will escalate this issue to engineering and keep you posted on the progress.


Thanks,

Pranav

Kinvey

WEB-2678

Login or Signup to post a comment