Start a new topic

Enterprise Authentication: KinveyError: A redirectUri is required and must be a string

I have enjoyed your tutorials on enterprice auth, and i have picked oAuth2 with azure active directory. 

I have gone through the tutorial 4 times now - including following every step of Alex Zinkins tutorial, but no matter what i do i end up in: 

KinveyError: A redirectUri is required and must be a string. 

when i press the "Go to login" button on the startpage

I have used SideKick to generate an app from the template Enterprice Auth. I have configured Azure AD Auth excactly like you suggest, i have linked my accounts and the service is created when i fill out the form in SideKick. Project builds fine but when i click the login button it throws the error. I can see the error comes from the autogenerated login method wich uses: this._userService.loginWithMIC(null, null), 

but no matter what we do it keeps throwing the same error. 

I have had a coworker sitting right next to me last time i did the tutorial to make sure that i wasnt missing anything... same error... I have been using 2 days now trying to get this to work to show it to my boss who fancies FireBase... but as we are doing a lot of nativescript i have to prove that Kinvey is a viable solution... but this kindda blocks me. 

Please help me out...

Kind Regards

Per Høyer

2 people have this question

No I havnt - support tells me to ask my question at stack-overflow. But i believe the SiceKick Enterprice Auth-template is not in sync with how backend works. 

No... They told me to ask in StackOverflow or this forum :-) And look how that went :-)

I beleive though that you should not use SideKick for this... I dont think the two products are in sync.

But who knows - i have tried the tutorial setup a couple of times - and... well its never going to work. Looking into firebase now


1 person likes this

I also have this question. have you find any solution here?

2 people like this
Login or Signup to post a comment