Start a new topic

"Group" collection

I'd like to use a "Group" collection in my database, but when I create it immediately disappears. Is the name reserved as system collection?

I tried to query that collection, and looks to be empty. Also tried adding and deleting documents from it and works.. the problem is only that I can't access it from Data Store and neither add BL from Collection Hooks.

Would it be best if I don't make use of it?

Otherwise, if it's unused, is it possible to have its name available for use, visible on Data Store and Collection Hooks?

Hi Davide, You don't see the collection in your console? I just tried replicating and I couldn't. More reading on Groups:
Uh wow, oops, I missed this one. I guessed there could have been something similar, but didn't read this on the guides before.

Basically this is what I've done:

- In Data Store I couldn't see any "Group" collection, so I thought I could create it like I did with the other collections I use.

- Pressed "+ New" button, set Collection Name to "Group" and pressed Create Collection button: the collection was created and shown in the list of collections on the left of the screen.

- Then, when I refreshed, the page the collection wasn't in the list anymore. So I tried to create it again.

- +New button, collection name: Group ...and this time of course the system told me: "The specified collection already exists"

So, there I realized I maybe shouldn't have done that :D

Is this normal, right?
Hi Caroline,

I'm guessing there is currently no access to the custom/reserved "group" collection through the web console. We can query the API directly just fine to access that data, but still cannot find any features in the web console (similar to how you can access the reserved user collection for simple data manipulation/hooks). If this is correct, any idea on when this feature might be implemented? Thanks.
Login or Signup to post a comment