Start a new topic

User Discovery not working at all


Further to this issue from earlier:

I have set the User collection to be private. Now, _lookup calls do not return anything except an empty array

POST to /user/kid_XXXXXXXX/lookup with body...


"email": ""


expected [{...}] but got []


OK, I just checked back and this seems to be working again. I'll keep an eye on it.
This is not working again.
Hi Pete, I am trying to reproduce this issue, but lookup seems to be working properly. If this happens again, could you make a note of the value of the X-Kinvey-Request-ID header returned to you from Kinvey and include it in a comment on this thread? this would allow me to trace the request and see your issue in action.
Hi Gal,

I'm intermittently seeing some strange behaviour here again.

Working example, authenticated as the target user

ReqId: df919ecb12a7428aa5e3c650e9a5d737

Working example, authenticated as a different user

ReqId: 0520d263951d4b8aaebac21dabe8617b

Failing example, authenticated as a different user

ReqId: b914becd25f64e47bf038bec2c025f2a

The _acl settings on these user objects are different, but as far as I understand it from the documents since they are all user objects in a private collection, and since the _acl objects do not block access, only grant it, this should not affect the operation of ../_lookup calls.

I'd be very appreciative if you could shed some light on why the first two worked and the third failed.



PS It would be useful to be able to write markdown in these comments. Would make them so much more readable.
Hi Pete, I have looked at your requests in the logs, and can see that all three actually received a user record from the server in response, so I am not sure what part is not working; perhaps you copied the wrong request IDs by mistake?

However, an entity's ACL record can in fact prevent it from being available to lookup. For this to happen, its "gr" (global-read) attribute must be explicitly set to false, indicating that it not readable by anyone besides the creator and the app admin.

Could this be the case you are encountering? if not, it would be helpful if you could reproduce the issue again, and provide me with a new request ID that returned an empty array. Additionally, please double check that there is no possibility that some errant code on your end is causing the unexpected result.

As for markdown, there is very limited support-- for example, you can create code blocks by indenting your code by four spaces, as mentioned here
Login or Signup to post a comment