Start a new topic

Collections Do Not Get Destroyed

I noticed this problem a while back and ignored it for the time being. However, now it's getting bothersome.

I have a collection called "messages". I imported data to fill it (more on that in the next support question I post). The import did not work correctly so the collection is full of garbage.

I clicked the "delete all rows". It deleted ONLY the rows displayed and then promptly displayed some more. There are 60K rows in here. The databrowser shows only 1 page even though there are hundreds of pages probably. I can't click "delete all rows" all day.

* Delete All Rows needs to mean ALL rows in the entire collection or you need it to say 'Delete All Displayed Rows'

* Paging needs to be fixed : (‹ Previous 1 of 1 Next › ) is not correct for this collection

So, I decided to just blow out this collection. I went to Settings and clicked 'Destroy Collection'. It took a few seconds, then the KInvey Console selected a different collection to display. The list of collections no longer shows "messages". Great.

Unfortunately, when I reload the DataStore page, my "messages" collection is there again.

The same thing happens to an empty collection called "Connections" that I've tried to destroy many times. It's just hanging around. LOL : Actually, I just tried to destroy it again. It seems to have worked this time.

Is your Messages collection still there, or is that gone now?
It's finally gone. I've dabbled with some other collections called "messages2" and "messages3". "messages2" displays the same problem with "delete all rows". It ONLY shows one row at a time and only deletes one row at a time. However, I finally managed to empty it (it had few records).

Basically, things work some time and not others. Something is wonky with managing collections and their rows in the console.
Login or Signup to post a comment