Start a new topic

no longer getting Push Notifications ?

until recently, i could receive push notifications (sent via the webconsole) on my iphone, all fine. Then i tried sending push notifications myself (delphi server-app with indycomponents, connecting to using the received devicetoken) but this failed, no push-notification ever arrived on my phone.

and now i no longer receive push notifications when i try to send them via webconsole. can it be i got locked due to some inevitable invalid requests to apples sandbox server ?

I'd recommend resetting the device token and seeing if that fixes the problem. Apple will sometimes disable a device until it reregisters, and urban airship doesn't give us good visibility into that.  We can look to see if a device has been disabled or not, but not if it was disabled previously or why it was disabled.  There isn't an API for this (or at least there hasn't been in the past).  Resetting the device token usually fixes the problem.
You should only send notifciations from the web console *or* from Kinvey Business Logic, as the tokens have to be sent via the push link we have with Urban Airship, otherwise Apple will mark the token as disabled.
> @Caroline said:

> I'd recommend resetting the device token

How can i do that ?

the only thing i found is to delete/destroy the kinvey user, i did so and created a new one with same user_name + password (so i dont have to recompile my mobile app) but keep getting the same device token.

Same devicetoken when creating another user with another name/password

I also deleted my App in the dashboard and made a new one with new name > same device token ... (1e205ecbb31b7054f82a3ff2a7fccf0c90a7b9cec99f8cece7d9129400b96e00)

i made a new set of certificates + provisioning profiles and switched from build:release / config:debug to build:release / config:ad-hoc in delphi and got a new device_token but same problem, no single notification arrives (i was asked at app start if i want to get notifications from this app and confirmed this)


i played around with the CFBundleIdentifier in Delphis Project settings > Versioninformation,

i had it at $(ModuleName) all the time, so i changed it to, got a new token and again no notifications,

then i changed it to com.appname only (erasing the prefix Z86V3S23...whatever), compiled again and got another device_token, one that i previously had when it worked and for whatever reason i get push notifications again ...

now the next task will be how can i send push notifications from my windows server application to a specific device token using the kinveyprovider
Hi Moe,

I've also been down this road.

If I can be of any help, let me know.

I have a fairly simple app receiving push notification, built in Delphi XE6 using the BaaS push object.

I'm also sending the pushes from a DataSnap server to Kinvey.

I'm using indy for that.
Login or Signup to post a comment