Start a new topic

iOS Push 2

Another issue.

I have two, possibly three testers that seem to not be able to get a Device token.

The other 20 testers are not having any problems that I know of.

These users with the problem have tried rebooting their deices, installing and re installing the app, and installing a prior version of the app.

Question; is Kinvey or Urban Airship involved in any way in getting a Device Token?

Hey Gary, this question will probably get a better response under the iOS category so I'm going to move it there.
ok, thanks
When you say "getting a device token" do you mean that the `didFailToRegisterForRemoteNotificationsWithError:` was called or neither that nor `didRegisterForRemoteNotificationsWithDeviceToken:` was ever called, or do you mean that these were called and the a device token was generated but the call to `KCSPush application:didRegisterForRemoteNotificationsWithDeviceToken:completionBlock:` was called but and the completion block was called where `success` was `YES`, but no token is present in the User object?

Also, what version of iOS & KinveyKit are you using?
Hi Mike,

I'm using the Kinvey provider that is part of Embarcadero's Rad Studio.

Neither OnDeviceTokenReceived nor OnDeviceTokenRequestFailed is firing after I activate the push events object

Nor does there seem to be any timeout. We have let the app sit for about an hour waiting and nothing happens.

This seems to occur on only two phones of about 20 testers. All other phones work fine and get the device tokens.

This is all on the same ad-hoc build hosted by HockeyApp, so I know the code hasn't changed.

I'm reading the Apple documentation right now and so far it seems that the token negotiation is only between the device and APS.

Pardon my frustration but it seems like I'm having to go into too much nuts and bolts depth for using a RAD development tool and a cloud service provider.

It's been one hurdle after anohter for the last couple of weeks to get just this far.

The server side code to call Kinvey was comparatively speaking a piece of cake, but then I wrote my own code to do the REST calls to the Kinvey custom end point.
We don't maintain the RAD plugin so I'm not sure why requesting the token doesn't generate a callback. I would say to make sure you're testing on an actual iOS device with an iOS that's not iOS 8. If that's the case, have them reach out to us, since I don't know if they are using our library or wrote their own.

According to HockyApp it's two iPhone 4 (CDMA) with 7.1.1 and 7.0.3

According to all of my reading on the Apple site they seem to say the token is between them and the device. So it seems like Kinvey is not involved.

This is only happening on two devices so I really don't think it is the code.

I was more wanting to know why the token request might be refused or ignored.

But if Kinvey is not involved then this might not be the best place to ask.

In another thread it was suggested to reset the token, but they didn't tell how to do that. And didn't respond when I asked how.
If the token is refused, such as the user disabling notifications or at least by rejecting your app's request, it should still generate a didFailToRegisterToken event. It's possible that their registerToken method has some persistent state and doesn't re-ask the device.
"user disabling notifications"

I just tried that. I think that is it.


I never would have thought...

Login or Signup to post a comment