Start a new topic

iOS 8 Push Notifications | Not getting devicetoken

Building project under iOS 8 SDK results in user's device token ( for push notifications) not being saved.

Under iOS 7 SDK everything works fine.

Do you have any updates on this one?



Thanks a lot! Check mail
Aris: Let's move this to email. Please email me a copy of the code that you're using to initialize push and I'll take a peek at it. My email is the same as my forum username @ Thanks,
Damien this issue is blocking my AppStore release. Please...I need a solution!
No, but we are getting there :) This is what we have so far: Users receiving push are * iOS 7 users running my app build with iOS 8 SDK OR * users that have devicetoken stored in _push field (these users were actually created over four months ago with my app built with iOS 7 SDK - let's call them "old users") Problem is with iOS 8 devices running my app built with iOS 8 SDK. "_messaging" is empty
Aris: Despite what's in the docs (they are just a little outdated) we are now using the messaging field rather than the push field. Items in the _push field will still get notifications, but new devicetokens will not be added to that collection anymore. All new device registrations will go into _messaging. Does that answer your question at all?
Hello Damien. I re-generated the push certificate and uploaded it to Kinvey. Users that already have a device token can now receive push notifications. Nonetheless new iOS 8 users don't seem to provide a device token upon signing in. In case this helps some of my users have a "_push" property including "devicetokens" while others have a "messaging" property including the pushTokens. My setup is exactly as presented in the docs.
Aris, At present we're not able to reproduce this issue internally. Following the guides published with an example app seems to work for us internally... Before we dig deeper into this issue, can you ensure that your implementation is exactly as presented in the guides? Thanks,
` [KCSPush registerForPush]; if (SYSTEM_VERSION_GREATER_THAN_OR_EQUAL_TO(@"8.0")) { UIUserNotificationType types = UIUserNotificationTypeBadge | UIUserNotificationTypeSound | UIUserNotificationTypeAlert; UIUserNotificationSettings *mySettings = [UIUserNotificationSettings settingsForTypes:types categories:nil]; [[UIApplication sharedApplication] registerUserNotificationSettings:mySettings]; }` Could this possibly be a solution to my problem? Registering for user notifications got me in Settings>Notifications but still no push.
My app supports typical push notifications for "Like" and "Comment" activities.

With iOS 7 users were able to trigger ( using post save business logic scripts) and receive push.

With iOS 8 app does not even request permission for Push Notifications.

Any ideas?

Can you explain how you are testing that users are not receiving push notifications? How are you testing? Are doing a targeted push to a single device or are you doing a broadcast push to many devices?

I can help you troubleshoot once I know more.

Which field should be updated when users sign in? "_push" or "_messaging"?

"_messaging" is updated but still users do not receive push while they did with iOS 7.

"_push" field is empty for iOS 8 builds.

Please provide further info in case I miss something . This is critical!


We have not changed anything with our method of getting the device token with iOS8, the method of obtaining the devicetoken remains the same for the sake of reverse compatibility for people already building with us.

We have an app setup guide here: that shows some additional setup required there.

There is an existing sample within an application here:

Any help on this one?
Is ` [KCSPush registerForPush];` enough for obtaining device token is iOS 8?

Sorry for the long follow up on this, are you still experiencing issues with iOS? 1.28 and subsequent patches to our backend have addressed all known issues with push.

If you are having issues, please let me know how to reproduce the conditions that you're having and we will move forward from there.

Login or Signup to post a comment