Start a new topic

Are Kinvey services down?

I am unable to connect Kinvey server and getting following exception.

05-17 04:40:10.091: W/HttpTransport(15249): Unable to resolve host "": No address associated with hostname

Any idea? looking like kinvey server is down!

We had some connection errors on Friday due to the database upgrade. All should be resolved, please let us know if it isn't.
Thanks, worked fine from next day

> @Caroline said:

> We had some connection errors on Friday due to the database upgrade. All should be resolved, please let us know if it isn't.

I am having the same kind of exception W/HttpTransport(15249): Unable to resolve host "": No address associated with hostname 

Could you please help me out


Can you ensure that you are not blocking outbound traffic to this ip range?  


hello there,

i am getting the following error I/ERROR sending to kinvey: ERROR

What does this mean? Is it because kinvey is down?

Hello Ramapriya,

I just checked with our DevOps team and there is nothing obvious impacting the Kinvey platform. Can you be more specific about the error that you are receiving such as:

  • What were you doing when you received the error?
  • Was there a number or text message associated with the error.
  • What is the name and KID of your application so we can check specifically.
  • At what time did you receive the error? The more specific you can be the easier it is to identify your Kinvey requests.
  • Anything else about the problem that you think would be helpful to us?

Billy Gee

1 person likes this

Dear Billy,

Thank you, my Kid is kid_W1EFbeKyy-, my app was able to successfully send data to the collection, somehow now it doesnt. I will paste my code below:


public class UserInformationClass extends GenericJson {

    // used to denote which field goes into which column of the kinvey table

    private KinveyMetaData.AccessControlList acl;
    private KinveyMetaData meta; // Kinvey metadata
    private String user_id;
    private String education_level;
    private String gender;
    private String education_background;
    private String birth_year;
    private String employment_status;}

 Below is how I try to push data to kinvey collection User_Info: 

UserInstanceClass user_instance = new UserInstanceClass();
                Log.d("HI", "get user_instance");
                AsyncAppData<UserInformationClass> myui = user_instance.getmKinveyClient().appData("User_Info", UserInformationClass.class);
                Log.d("HI", "meow");
      , new KinveyClientCallback<UserInformationClass>() {

                    public void onSuccess(UserInformationClass userInformationClass) {
                        Log.d("HI", "meow1");
                        Toast.makeText(GetUserInformation.this, "Data successfully received", Toast.LENGTH_SHORT).show();

                    public void onFailure(Throwable throwable) {
                        Log.d("HI", "meow2");
                        Toast.makeText(GetUserInformation.this, "Data not sent error", Toast.LENGTH_SHORT).show();
                        Log.i("ERROR sending to kinvey", "ERROR");

 UserInstanceClass get the client object for me in the following way : 

public class UserInstanceClass {
    // all instance share the same instance of this variable
    static Client mKinveyClient;

    public static void setmKinveyClient(Client mKinveyClient) {
        UserInstanceClass.mKinveyClient = mKinveyClient;

    public static Client getmKinveyClient() {
        return mKinveyClient;

 The way I initially connect to the app is like this : 

UserInstanceClass instance_user = new UserInstanceClass();
 instance_user.setmKinveyClient(new Client.Builder(this.getApplicationContext()).build());

 I intially tried to create a new collection and the columns, somehow the columns keep dissapearing, so I tought

i could push rows as objects like UserInformationClass. the error I get is : 

05-11 23:34:44.615 22442-22442/com.example.ramapriyasridharan.trialapp04 I/com.example.ramapriyasridharan.trialapp04.MainActivity: Unable to resolve host "": No address associated with hostname
05-11 23:36:18.647 22442-24177/com.example.ramapriyasridharan.trialapp04 I/dalvikvm: Could not find method, referenced from method<clinit>
05-11 23:36:18.697 22442-22442/com.example.ramapriyasridharan.trialapp04 I/ERROR sending to kinvey: ERROR
05-12 00:26:52.963 22442-22442/com.example.ramapriyasridharan.trialapp04 I/ERROR sending to kinvey: ERROR
05-12 01:42:45.501 22442-22442/com.example.ramapriyasridharan.trialapp04 I/ERROR sending to kinvey: ERROR

 Hope you can help, thank you.

Login or Signup to post a comment