Start a new topic

Phonegap push notifications Sample doesn't work

Hello, I have downloaded your sample for push notifications on Android via Phonegap. I have changed the required IDs and GCM keys which were required and uploaded it as .zip in,

After the build I tried installing it on some android devices it was installed successfully but the Register device button doesn't work. When I press unregister it says it is already unregistered. But when I press Register device button it doesn't take any action.. What I'm doing wrong??

PS: At config.xml I have changed only the phonegap version to 3.3.0 how it was required at webpage. I use the online building method because I can't get running well with Phonegap CLI yet.. and all the tutorials are for MacOS operating system I need one simple step by step tutorial for Windows

Reports on the official PhoneGap plugin page [here]( indicate that the plugin may not work with PhoneGap build. In case the CLI doesn’t work on Windows, you could always try running the CLI through a Virtual Machine with Linux installed on it. That might give you better results.
Finally I succeed to get cordova installed into my Windows machine, I had some other projects working on till now and now I completed the requirements to go on. So please help me how to implement and build push notification app because I'm a beginner in Phonegap and Push notifications. I want to implement them for Android only for now I have GCM project ID, and the required keys added to kinvey console app.
What problems are you running into? Can you describe to me the steps to take, so I can try and play with it?

Have you followed the [Push Set-up Guide]( for your project? Also, note testing Push Notifications is a bit tricky - the guide contains short instructions for Android in the yellow alert box from the link above.
I followed this steps:

phonegap local plugin add org.apache.cordova.device

phonegap local plugin add org.apache.cordova.dialogs

phonegap local plugin add org.apache.cordova.vibration

In the 4th step I had a problem as you can see in the attachment. The folder is located in Desktop and YES I have permission to edit that directory

![]( "")

Looks like this is a bug in git - I found a similar question [here](

So, the following command might fix things:

`mkdir C:\Users\Afrim\AppData\Local\Temp\plugman\git`
Ok I got it, this problem is solved.. I have build the sample Push from your site I installed it on my tablet no error is showing but when I press Register for Push button status is saying registering... and it freezes right there. What can be the problem there ?

PS: Is the APP Key the Kinvey App ID, this one kid_*****_*?
Login or Signup to post a comment