Start a new topic

Strange behavior from Applicant Tracker.

Hello Kinvey,

I'm working on getting the Applicant Tracker up and running.. but I'm coming across some strange behavior. It works for me sometimes, but other times it doesn't. When the webapp isn't working, users who have Github profiles will not load, even though the API fetch appears to have completed successfully.

The error is "Uncaught TypeError: undefined is not a function" Given that the app works sometimes and not others, I'm worried this could be a race condition, which I'll definitely have trouble debugging.

Here is the output from my dev console:

Here is the referenced code from the dev console:

* [VM1092:6]( "VM1092:6")

* [underscore.js:1165]( "underscore.js:1165")

* [applicant-detail-view.js:39]( "applicant-detail-view.js:39")

* [router.js:212]( "router.js:212")

* [backbone.js:438]( "backbone.js:438")

* [kinvey-backbone-1.0.4.js:9081]( "kinvey-backbone-1.0.4.js:9081")

* [kinvey-backbone-1.0.4.js:884]( "kinvey-backbone-1.0.4.js:884")

* [kinvey-backbone-1.0.4.js:2]( "kinvey-backbone-1.0.4.js:2")

Any pointers in the right direction would be helpful.

I realize some of the code is the source, but given it's published on github and doesn't contain keys, I don't think it's a problem.

[]( "")


p- test



Also, it's important to note that users without Github ID's attached to their name in the datastore have no issues rendering in the app.
Hey jwleaman,

Did you modify the code at all or just run exactly as was? Just trying to rule out possibilities.
No... Just added my keys and updated the datastore. I will try rebuilding the app as a next step.
Login or Signup to post a comment