Start a new topic

Issue with command line on Windows 8


I have downloaded the latest version of the cli. (0.3.2).

The tool is working fine but each time that I invoke a command I got an Exception popup saying:

_Runtime Error!

Program : kinvey.exe


An application has made an attempt to load the C runtime library incorrectly.

Please contact the application's support team for more information_

The command just succeed after i close the popup, but this is a bit annoying....



Hey Avi,

That sounds pretty buggy. We'll take a look, thanks for bringing it to our attention.
Sorry for the late response. I am unable to reproduce the issue, but it certainly looks like something is going wrong. Is there a way you can try the CLI tool on Windows 7, and let me know if that yields the same warning?
On my Windows 8.1 64-bit system, I get exactly the same popup. It is not a blocker, but it gets real annoying. It makes it hard to use the kinvey CLI Grunt plugin.

Kinvey-CLI Version: 0.3.3

The header for the popup is "Microsoft Visual C++ Runtime Library" This error usually means one of two things.

1. The system does not have all the necessary Microsoft Visual C++ Runtime components installed.

2. problem with the software.

Checking on the first possibility, I dropped kinvey.exe into Dependency Walker and it is failing to find the "API-MS-WIN-SERVICE-PRIVATE-L1-1-1.DLL". This is often a false positive, so it might not be that helpful. I can't do a dynamic test since it craps out dependency walker before I can start the profiler.

Visual C++ Runtimes installed on this computer (I only included the 32-bit ones):

* 2005 Redistributable Version 8.0.61001

* 2005 Redistributable Version 8.0.56336

* 2005 Redistributable Version 8.0.59193

* 2008 Redistributable - x86 9.0.30729.17

* 2008 Redistributable - x86 9.0.30729.4148

* 2008 Redistributable - x86 9.0.30729.6161

* 2010 Redistributable - x86 10.0.40219

* 2012 Redistributable - x86 11.0.60610

* 2012 Redistributable - x86 11.0.61030

Hope this helps. I can't really go into it farther on my end. Let me know if listing the installed 64-bit runtimes would also help you.

I do not have the error on OS X. I have no way of testing this on Windows 7. It probably works on Win 7 since there were some changes in Win 8 and 8.1 that I have run into when developing apps in Qt. And there is stuff on Stack Overflow about similar Win 8/8.1 problems. Hopefully, we just need a different version of one the runtimes installed and it will work.
I just rebuilt the library on Windows 8 - can you try [version 0.4.0](
I'm seeing this same error on version 0.4.0
@Mark, the link to download the cli you gave is incorrect
Yeah, that link might not work for everyone - [this one]( does.

I am still not sure where the errors come from. Do you run the CLI using administrator permissions?
Hi @Mark, unfortunately, still got same error

The dependency walker doesn't give any issues for me, also my system has the 2008 Redistributable - x86 9.0.30729.4148 runtime so that looks fine too.

Could you try executing the command `PATH=kinvey.exe` right before running `kinvey.exe init`? It could be that third party applications are interfering with the CLI.
Login or Signup to post a comment