Start a new topic

app engine adding url crash web console

today suddenly we got error on every hook attached to app engine 

{

"error": "BLRuntimeError",

"description": "The Business Logic script has a runtime error. See debug message for details.",

"debug": "ReferenceError: onPreSave is not defined"

}

and i found that the url of the app engine is not saved, and when i tried to add it the web console crashed.


Elnaqah:


I don't think that anything changed, it looks like you uncovered an existing error.   


Thanks,

yes it worked.
thanks .


but can i ask what made the app engine hook change ?

Elnaqah:


Rather than leaving the text area blank, can you please place the default text in there and try hitting save


function onPreSave(request, response, modules) {


}


Thanks,

thank you for the support , this case is a disaster for us.

Thank you for the additional information Elnaqah, we'll do some digging on this and get back to you.


this is a screen shoot for the error returned when  a post request sent to a collection hooked to app engine on preserve

png

attached a video for the problem 

mov
(1.93 MB)

attached video for the problem 

mov
(1.93 MB)

Elnaqah:


I am still unable to reproduce this issue, can you please take screenshots, a video, or provide steps to reproduce this?


Thanks,

now i can't add app engine url to the hook the web console crash each time , i add the url to the hook

Elnaqah:


I just attempted this and I am unable to recreate the error at this time,  can you please provide me with more clear steps to reproduce?


Thanks,

any request to collection hooked to app engine 


Elnaqah,


Can you please provide the code that is causing this error?


Thanks,

Login or Signup to post a comment