Start a new topic

Push notification!!

Here is the situation. 1. Push Notification is working perfectly fine in Development mode. I can send and receive notifications real time. 2. Filters when sending notifications inside Kinvey are also working 3. The problem is when I enabled the Production Mode, and rebuild the app to AdHoc / Release version, I can still send notifications without any error. In fact, Kinvey returns success status and even states how many users accepted the notifications. However, in the actual device, I get nothing. I already updated the my .p12 file and uploaded the production version inside Kinvey. And I also already set the Production Mode. HELPP

Tom, I need to ask you some questions before I'll be able to help you: Can you tell me how you are sending the pushes (in the app via SDK, Through the API, Business Logic, etc) Do you have the 1.28.0 SDK for your application? What version of iOS are you targetting? What is the kid of your application? What are the device tokens that you are targeting? Thanks,
We tried using Kinvey’s test platform, as shown below. We also tried using Business Logic inside the web app. 2. Yes, i have SDK 1.28, recently downloaded from Kinvey’s website. 3. iOS 8 is the target iOS version. The same with the development mode, which is working fine. 4. I don’t understand about what kid? 5. The tokens are the one in our Users collection, Example are: :”35777a3996da9dde4af2c989b95d3e82fc59f188fc9ee259e4c53e58a1561f73” and “a7d7c1c7f96850519970bc33f0125a28cde48a5697ba542ac76cef8ed59397a8”. I am wondering, if there is a way for them to reset our Push Notification configuration inside Kinvey. Because it may have been corrupted already or something. If they can reset it back to its original status prior to the submission of the first Certificate. There maybe files inside that could no longer be overwritten by the new certificates that I submit.
Good afternoon Tom, Could you try cloning your collection to check to see if this is just a configuration as I don't believe that push settings are cloned with the environment. Thanks,
The cloning for Kinvey seems to be not working. First, it is no longer part of the new UI. I had to find it inside their legacy system. And when I tried cloning, the system doesn’t allow me to select destination environment.
Tom, You need to create another environment within the same app. Thanks,
Has this been answered? I am having the same problem and do not see how to clone a collection nor do I see how to create another environment. Please this is a big part of Kinvey that is not working.
Hello, We are having some internal discussion around this today and will be back in touch shortly, Thanks,
Login or Signup to post a comment