Start a new topic

UI related bug at

On App-Cost-Estimator, there are two small possibilities of improvement to bring consistency:

1. Not a big deal:

In the question, "Will you need to integrate any existing data sources?", the user can not deselect the answers by re-clicking on "Simple" or "Advanced".

For other questions (scroll one question up for example), it is not the case. In the question above, I am able to select "Data" by clicking on it, and deselect it by clicking on it again.

This problem occurs in some of the questions, while does not occur in others. I tried to look for a pattern but failed to find any logical reason to believe that this was intentional.

2. Prone to give wrong results to the user:

In the question, "How will you engage with your users?" there are three possible answers: "None", "Push/SMS/Email" and "Advance Social Integration". Clicking any of these choices selects it and this selection changes the price calculated.

WHILE, clicking the answer again deselects the answers as it should but does not change the calculated price back to what it was.

Rectifying this small bug will be beneficial for Kinvey. Since the advertising is done by comparing the costs of Kinvey and DIY, having lower cost on Kinvey side is favorable.

I am attaching three screenshots named:

BeforeSelectingAnything.png (Note the price to be $40,962)

AfterSelectingTwoChoices.png (Note the price changing to $45,590, as it should)

AfterDeselectingTheChoices.png (Note the price still being $45, 590 when it should be $40, 962 again)

I hope my explanation makes sense and this is rectified soon. I am myself a software developer and have worked as a web developer, hence I know this is not a very time consuming issue.


1 Comment

Thanks for letting us know Avi, that does seem to be an issue.

Enjoy your evening :)

Login or Signup to post a comment