Start a new topic
Answered

Push Not Working, Again?

 Hi,

I am seeing this as the result field on the PushMessage callback.

Does this indicate it worked or not?

{"pushedTo":{"kid":"kid_VTagZneFqE"},"rawResults":{}}

 Nothing is sent to my phone.

Gary


Best Answer

Gary,


At present we aren't having any known issues sending / receiving push notifications from our platform at this time. It concerns me that the password you gave me for your push cert (which worked for me) is not the same as the one you gave out above.  Did you regenerate your push certificate?  


Thanks,


 Hi Aris,

Nice to know someone else is having the same problems I am.

That tends to assure me that it's not my app.

One thing, right now I am not able to successfully upload certificates.  Kinvey keeps saying it can't validate them.  I have tried with both Firefox and Safari.

Gary

Sorry for taking so long to get back to this.  Had some issues with iOS 9.

ok, I created a new test app so everything is starting from scratch.

I created and uploaded a Development SSL Certificate.

The following was crated in the user record when running the app:
{
  "pushTokens": [
    {
      "token": "808b2cc50dafda2d008107bd3d2114386b5b65cb4a40d362ba592b4791808fe7",
      "platform": "ios",
      "arn": "arn:aws:sns:us-east-1:853461911189:endpoint/APNS_SANDBOX/kid_Wkdx_osbwe_development/371eb3ac-30d0-378e-afe1-1536999c6f66"
    }
  ]
}

 When I send a push from the Engagement page I get 202 Accepted

What does that mean, why not 200?

Nothing shows up on the iPad.  Not in the app nor in the Notificatuions area.

Now what?

Gary


 

Aris,

Something else, for me pushes to Android devices work.  It's just Apple (iOS) that they don't work.

Gary

 

 Hi,


I found the problem with the Android side.  It was an error in the Manifest File.

I re-uploaded the Apple certificate.  It didn't give me an error, but it didn't give me a confirmation either.

The iOS still doesn't work.

You have the login information

It is a production certificate because that is the way RadStudio does things with Ad-Hoc builds.

Gary

 Hi Gray,


Can you please try re-uploading your APNS certificate (which is a .p12 file) to the Kinvey console using Safari / Chrome browser. This could solve your problem.


Thanks,

Jagan

Hi Gary,


The push field looks normal to me.


Can you share following couple of items to give me a better idea:

  1. A timeline of events related to push functionality (when it started working, stopped working, issues faced, different things tried etc.)
  2. Your code relevant to push functionality (registration, receiving notifications etc.)
  3. Kinvey app id
  4. SDK version

Regards,
Wani

Hi.

1. For the test app I created last night it has never worked.  For our three production apps it stopped about 2-3 months ago.  For the production apps we tried re-uploading the certificates, that didn't help. We tired altering the business logic code as instructed, that helped temporally but crippled out app and then finally quite working.  For the app I created last night everything is new and newly uploaded.

2. We are using a built in control in Embarcadero's Rad Studio. I can try to capture the REST commands sent if that would help.  However, you indicated the registration is working correctly.  The reception when the app is closed is handled by iOS and should appear in the Notifications area.  It does for other apps, such as Mercat.  This is using iOS 9.0.0

3. The app name is pushtest2.  The App Key is kid_Wkdx_osbwe.  I am not sure what you mean by app id?

4. API version is 3

By the way, this is affecting all of our apps and on multiple different phones, and both Android and iOS.

Gary

Hi,

It seems to all be working now, just as long as I upload the certificates using Chrome on a Windows 7 platform.


Which of course means I have to copy the certificate from the Mac to the Windows machine, and then upload it.

Gary,


Can you email me about this?  Damien@kinvey.com -- and add me a collaborator.


Thanks,

Gary,


I was able to upload the new Push Cert without issue to your environment today using Chrome on Windows.  Can you tell me which browser you were using?  


Please note, you may need to re-register your devices before they are able to get push notifications.


Thanks,

I was using Safari on a Mac.

I upload the screen shots showing the results and the about info in response to an earlier post.

So are you saying only Chrome works?

Gary

 

Gary,


For the time being we're doing multi-variant testing on the page to see what browsers / versions are having issues.  We've been unable to reproduce the issue reliably at our office, so we're still working to achieve that end.  We've been working on this internally for some time now.


Sorry for the inconvenience. 

 I don't like chrome already.  It's asking me to login to google to use it.

HI Damien,

Just tried with Chrome.

Got:

 
There was an internal server error when processing your push configuration. Please verify that password is correct and certificate is not expired.


So WHAT am i don't wrong???

Gary

You can hit the skip button and it should let you not login to Chrome, it does that to enable you to import bookmarks / settings (extensions, etc.) across devices (they tie them to your Google account).

Login or Signup to post a comment