Start a new topic
Answered

Push Notification Extra Data is missing on iOS when the app is started from the notification

Hello all,


I am writing an application using RAD Studio and the TKinveyProvider module.


In the business logic, I'm sending the basic APS informations along with some iOSExtras. And that works fine.


When receiving the notification while the application is running, it's not a problem, the extra data is present.


When the application is in background mode, I'm receiving the notification and the message is displayed in the notification center.

If I click on the notification, the application start but the Extra data is not present in the content of the notification.


I followed this tutorial from embarcadero:

http://docwiki.embarcadero.com/RADStudio/XE8/en/Multi-Device_Application_to_Receive_Push_Notifications


I've looked into the documentation and saw the PushEvents.StartupNotification property, but it doesn't contain the Extras

http://docwiki.embarcadero.com/Libraries/Seattle/fr/REST.Backend.PushDevice.TPushEvents_Properties


Can someone point me in the right direction?


Thanks!


Best Answer

Hi Stefan,


We do not officially support RAD studio. The TKinveyProvider module has been out of date for quite some time now. And I don't think Kinvey's updates to Push architecture and SDKs have been propagated to this module.


Can you get in touch with embarcadero support with this issue?


Regards,

Wani

Kinvey Support



Answer

Hi Stefan,


We do not officially support RAD studio. The TKinveyProvider module has been out of date for quite some time now. And I don't think Kinvey's updates to Push architecture and SDKs have been propagated to this module.


Can you get in touch with embarcadero support with this issue?


Regards,

Wani

Kinvey Support


Hello Wani,


Thanks for your answer, in the meantime, I've looked into updates from embarcadero, since it seems the problem is coming from their side indeed.


Regards,


Stefan.

Just to clarify... it's not when I'm in background mode, it's when the application is closed. Sorry for the wrong statement, but I couldn't modify the text after submitting it.


I'm receiving the push notification, the only thing is that I do not get the Extra data which contains the ID of the object I want to load from the backend at startup.

Login or Signup to post a comment