Start a new topic

Titanium 3.X SDK


I've just started a new Appcelerator Titanium project and I'm trying to add Kinvey SDK to it. 

However, the app throws an error at start and the only thing that I have in my app is the SDK. No extra code, nothing. And I've even removed the "init" method. Only the require() remained. 

I've tried with different versions, for example:

v3.0.0-beta17 throws:

[ERROR] : Script Error {

[ERROR] : column = 134;

[ERROR] : line = 4532;

[ERROR] : message = "Can't find variable: Symbol";

v3.1.0 throws:

[ERROR] : Script Error {

[ERROR] : column = 168;

[ERROR] : line = 23768;

[ERROR] : message = "Super expression must either be null or a function, not undefined";

I've even tried with different versions of Titanium SDK, 5.4, 5.3, 5.1, etc

Same Problem here :(

Hi Mihai and Nico,

Thanks for reporting this.

I have notified the SDK team about this and they're already on it. They ahve already fixed the broken API reference -

I should have an update on the rest soon.



Kinvey Support


More info :

Appcelerator Command-Line Interface, version 5.5.0

Operating System

  Name                        = Mac OS X

  Version                     = 10.11.6

  Architecture                = 64bit

  # CPUs                      = 8

  Memory                      = 17179869184


  Node.js Version             = 5.11.1

  npm Version                 = 3.9.0

Titanium CLI

  CLI Version                 = 5.0.9

Titanium SDK

  SDK Version                 = 5.5.0.GA

Alloy 1.9.2

Xcode 8 (just installed, 7 was not working either)

Anything new on this? Would like to use "the new Stuff".

Hi Nico,

The Engineering team is still working on this. While they are past the initial issues, there still are some other issues with Titanium.

I will get back to you as soon as I have an update/ETA on this.


Hello Nico,

I want to follow up on Wani's update. Engineering has confirmed that there will be an update of the Titanium SDK sometime next week. Their goal is mid-week or sooner if possible.

We will let you know if that changes and confirm when it is available for download.



Every time I saw a notification I was hoping it was fixed :)

I wonder how this got past the QA for so many versions...

Hello Mihai,

How long have you seen this problem?



Hey Billy,

4 days ago, when I opened the ticket. As I've said, I've tried with all the 3.X versions and with Ti SDK I've reached 5.1.0 and nothing works. Not even one combination of Kinvey and Ti SDK

Hello Mihai,

Thank you for the quick reply. We will let you know when we have a target date and/or update available.



Hey @all - any news around? 

Best, Nico

The mid-week goal is here...

1 person likes this

Hello Mihai and Everyone,

We appreciate your patience as we try to resolve this problem. I just spoke with Engineering and they are going to have to delay this update. The problem turned out to be more complicated than originally thought and we had to engage the Appcelerator team to assist with a Titanium bug.

The revised target date for a new update is Tuesday of next week, September, 27, 2016, Eastern Time. We will try to release it sooner if at all possible.

Please let us know if anyone has any questions.


Billy Gee


thanks for the update! :) 

Login or Signup to post a comment