Start a new topic

No credentials found or missing/malformed header v3.4

Hi Guys

This is a tricky one but not sure how to solve it. I have code that initializes then creates an implicit user. All working fine however I have one organization that is cannot create a user. I get a "InvalidCredentialsError" and every now and then I get undefined error "KinveyError

The InvalidCredentialsError is telling me that there is invalid credentials or a malformed header. I am getting this message whether I am just signing up an implicit user or of I am actually signing into an account with valid credentials. 

The organization having the problem has an environment that is somewhat restricted i.e. it would probably go out through gateways and monitors traffic etc. So I am guessing there is something happening along the path. 

People in the organization regularly sign in and authenticate with other websites and web apps without a problem so it has to be possible, there just seems to be something specific with how Kinvey is authenticating etc

I setup a SSL just in case it was preventing sending credentials to a unsecured address but that did not work. 

I am hoping blindly for some ideas. I accept that its probably their environment that is creating issues but they represent 20000 potential users and if I can't create or authenticate users they can't use the site at all. 

Code for implicit user


  appKey: 'xxx',
  appSecret: 'xxx'
}).then(function(activeUser) {
  if (activeUser === null) {
    var user = new Kinvey.User();
    var promise = user.signup().then(function onSuccess(user) {
    }).catch(function onError(error) {
}).catch(function(error) {

 I have attached 3 images

1) the undefined error

2) InvalidCredentialsError

3) Request/response headers

Sorry for the vague issue but I have no control over the environment and can't get it to work. 

Praying someone can help :)

(192 KB)

Hi Pranav

Yes that is the error I am getting (missing/malformed header)

Just updated to 3.4.4 and tried to the code. Getting same the result. You should see errors at the time of this post. 

Yep the code works fine in all the other environments I have tried it in. Only seems to be this one. 



Hey Pranav

Sorry no it is kid_Byxytefig. I am helping out with another project. I don't have the time-stamps but the time would have been around 14:00 Australian Eastern Standard Time on 13th March 2017

I Hope that helps

See anything in the logs? Only have easy access to this environment for two more days. :)


This has been escalated to engineering. Will update you once I get more information from them.







  1. Does it consistently happen or it does work at some point?
  2. Have you tried it with different browser?



Hey Pranav 

Yes mate, happens 100% of the time. The only variation I get is sometimes it will take much longer to error (guessing like a minute then throw that undefined error). 

Yes have tried IE and Firefox. Unfortunately they are the only two browsers I can get access to. IE has the same issue. 

Sorry for this I know it is a hard one. But if we can find why it gets stopped might help you guys make autho more robust. 


I was reviewing logs and found only one request with InvalidCredentials error on 8th March. Can you please let me know specific timestamps when you saw this issue?

Also, can you confirm the kid of your environment? Is this "kid_rywxSOz7g"?





I reviewed logs for provided kid and timestamp (13 March 2017) but didn't find any requests with "InvalidCredentials".

I found "InvalidCredentials" requests for 30th March and it says 'missing/malformed header'. Does the same code work properly in other environment?

We have just released html5 SDK v3.4.4. Here is the link Can you upgrade and see if it makes a difference?



Login or Signup to post a comment