Start a new topic

Newly created columns not showing up in Kinvey Console 5.0

Hi Guys

Using the new console.

Seem to be having problems with columns being displayed in the new console. Newly added columns wont show up and sometimes I can't add them. 

Sorry don't have perfect preconditions but here is one use case

1. Collection browser open with collection - can see columns

2. Run business logic that has update and adds new column

3. Query collection to check column exists - yes it does, returned with fetch

3. Refresh collection view - no column

4. Hard refresh page - no column

Not sure what is happening. I have also had trouble just adding columns via the browser, seems to be intermittent. Will look for preconditions. 

Best Answer

Hello Phil,

The reset button has worked to clear this problem for other environments so this is puzzling. I would like to ask you to try the reset again and see if that clears the problem.

If it still doesn't clear the problem, please click the column icon (the black square next to the + Add Column" link) and this time click the "Hide All" button and go back to explore the collection. You should see no columns at that point. Then go back to the Columns popup and click the "Show All" button. Then go back to the collection and see if you see any or all columns.

If that doesn't fix the problem, then try the reset button again one more time and see if that worked. If it doesn't then we have a different problem that we will need to investigate further.

Also note that the little black square icon next to the "+ Add User" link should look like a little spreadsheet with a heading and three columns, not a black square.

If none of this works, I have another step we can take. Also, Engineering is already looking at this issue so we may know more shortly as well.

Please let me know if you have any questions, otherwise, we look forward to hearing back from you.


Billy Gee


Thanks for letting us know. Glad it is working for you.
Let us know if you face any issues again.



Login or Signup to post a comment