Start a new topic

Kinvey Xamarin starter app won't run on device

I'm running Visual Studio for Mac and everything is up to date--iOS, OSX, Visual Studio, all of it.


I tried to download and run the starter project and got tons of errors, and spent a long time tracking all of them down. Most of them were solved by using nuget on one thing or another--all told I had to nuget about 15 different things to stop getting nuget-related errors. But that was pure detective work: I just read the error messages, and anything that looked like a package I went and downloaded from nuget.


Anyway all that nugetting got the project working on the iOS simulator, so, yay.


But it just will not run on my actual iPhone 6s.


This is the error I can't squash:


[my Kinvey/Xamarin project directory]iOS/MTOUCH: Error MT2101: Can't resolve the reference 'System.Void PubnubApi.Pubnub::AddListener(PubnubApi.SubscribeCallback)', referenced from the method 'System.Void Kinvey.RealtimeRouter::Initialize(System.String,System.String,System.String,System.String,Kinvey.AbstractClient)' in 'PubnubPCL, Version=4.0.2.2, Culture=neutral, PublicKeyToken=dc66f52ce6619f44'. (MT2101) (KXStarterApp.iOS)


...any helpo? It's been about a week I've been trying to get this app running.


Jesse,

Thanks for providing all this information. Will look into this and get back to you.

Thanks,
Pranav

 

Okay well this is weird. On the Kinvey-provided starter app, I only got that error when I tried to run the app on  an actual device. Having followed the Getting Started Guide for a written-from-scratch app, I'm getting the exact same error when I try to build at all.

Correction: now everything is v3.0.19, which I see just came out.

Hi Pranav,


Just to confirm: have installed v3.0.18 using NuGet. Error still appears. Am continuing to learn Xamarin but would still like to be able to get the starter app working.

Pranav,


Thank you for your attention and I feel I must apologize. 


I do not know if it came across in my post but I got defensive and, to my eyes, a little brisque. I appreciate your help and I'm sorry for being short with you.


To be fully honest, I am just learning both Kinvey and Xamarin. I have a good deal of experience with Swift and Lua, but C# is new to me, as is the structure of a Xamarin project. 


I was looking forward to a starter app as a good way to jumpstart my learning curve. When I reached a dead end with it I tried to follow the Getting Started guide. It quickly became clear I needed to know more about Xamarin to even follow that guide. So right now I am teaching myself Xamarin so I can follow the guide, on the one hand, and on the other I am posting on these forums about the dead end.


I will try to do what you suggest about the SDK and I will report back.


Thanks again,


Jesse

Jesse,

Thanks for all the details.

I just wanted to confirm, does starting with a new project from scratch using our 'Getting Started' guide work on your phone. That's why I shared that link. From all the details that you have provided, looks like you get the same error on both the starter app as well as new app on your phone but everything is working fine on simulator.

Also, there is one more thing for you to try before I escalate this issue. I reviewed logs and found that you are using Xamarin SDK v3.0.15. The latest version is v3.0.18. Can you please update the SDK and let me know if you still see any issues on your phone. Following is the link to download the latest SDK:
https://devcenter.kinvey.com/xamarin/downloads#


Thanks,
Pranav

 

I am not sure how I was unclear in my post.


The getting started link you gave me is for manually integrating Kinvey into a new app or an existing app. It does not appear relevant because I am referring to the starter app.


What is relevant, in this case, is the guide for installing the Kinvey Xamarin starter app.


What is also relevant is that I have followed that guide precisely and I have the app working. 


I have it running in the iOS simulator. It successfully adds a book to the backend database I've set up on Kinvey. It works just as expected: I push the button on the simulator to add a new book, I push the button to sync, then I go to the Kinvey cotrol page for that project, and I see the new addition to the database.


The single problem I have is that the app will not run on my phone. 


The error is as I reported above.

Jesse,

Thanks for moving your question to 'Xamarin' section.

Just to confirm, have you reviewed our Getting Started Guide? I would recommend you to go through our guide step by step. If it doesn't help at all, then I will escalate this issue to engineering.

Looking forward to your reply.

Thanks,
Pranav


 

Login or Signup to post a comment