Start a new topic

Oauth Errors with Linkedin

I believe I've set everything up properly, but when i try and do a login via:



$scope.login = function() {

var promise = $kinvey.Social.connect(null, 'linkedIn');

promise.then(function(user) {

console.log(user);

})

}



I've setup the $kinvey.init() with my appKey and appSecret.



I get the following error:

http://dl.dropbox.com/u/68704/Screenshots/al_g.png



My Oauth data store:

http://dl.dropbox.com/u/68704/Screenshots/ohl3.png


' is supposed to be a single quote.
Looking at the logs, it seems Angular messes up the redirect url called by LinkedIn. Can you try manually specifying the redirect:



```

$kinvey.Social.connect(null, 'linkedIn', { redirect: 'http://localhost:9000/' });

```
Still no dice. I've tried it with no url, my local url, google.com, anything. Nothin works!



```

Object {name: "IncompleteRequestBody", description: "The request body is either missing or incomplete.", debug: "Missing required attributes: oauth_token, oauth_token_secret, and/or oauth_verifier"}

```
Hi Dave - Just a thought, if possible, maybe try using a standard URL (non-localhost/custom port) for the LinkedIn redirect and see if that helps at all?
Yep, Twitter auth works just fine!
Hey Dave, I understand you're still stuck. Did you get twitter auth working?
I believe I have set up the URLs correctly:

http://dl.dropbox.com/u/68704/Screenshots/f_yp.png



I'm going to try twitter this morning and see if I can get a different result.
I think you should be seeing an access_token being sent, hence the error you are seeing.



Do you have the oauth redirects set up properly via your app entry on LinkedIn?
I've yet to try anything but LinkedIn at this point. :)
Here's a screenshot of my request headers:

http://dl.dropbox.com/u/68704/Screenshots/13nb.png
Can you provide a screenshot of the request headers? I'm not seeing anything immediately wrong with your setup.



Is only LinkedIn giving you problems?
OhmzTech: Yes I did.

http://dl.dropbox.com/u/68704/Screenshots/kk1a.png
Hi Dave,



Did you set up the business logic required for social authentication?



http://devcenter.kinvey.com/html5/tutorials/how-to-implement-safe-signin-via-oauth
The exact error seems to be `Missing required attributes: oauth_token, oauth_token_secret, and/or oauth_verifier`, even though I'm fairly certain I have those in place.
Login or Signup to post a comment