Start a new topic
Answered

iOS Certificate not working

 Hi,


I export the APN certificate from my mac and try to upload it to this page:

https://console.kinvey.com/environments/xxxxxxxx/engagement/push/settings

But the iPhone icon does not turn green and the Drag Files Here remains.

What is wrong???

This is a production certificate.

Gary


Best Answer

Hrm, that's strange, we cannot seem to reproduce that here (and our servers are off-site) can you try clearing your cache?


It depends on when you tried it.   I was testing on a mac, an iPad, an Android, and two windows 7 machines.  Somehow I don't think it was the cache.  In many cases it was the first time visiting Kinvey on those devices.

They all started working again about 2am this morning.  Maybe someone rebooted the server?

The net result is that it was down for 12 hours and no one was responding to this thread during that time.

 

Answer

Hrm, that's strange, we cannot seem to reproduce that here (and our servers are off-site) can you try clearing your cache?

Internet Explorer 11 just says loading too.

The mac still says loading, so it's been loading for over a half hour.

 

Well, there is problem.

At one time from Safari I was able to logon adn upload a certificate.  But now I can't even logon.  It just says loading....

I tried closing Safari and relaunching it, no go.  I tried rebooting the mac, no go.  I tried loging on from my iPad, no go.

I am attaching a screen-shot of the mac.

Gary

 

PNG
(191 KB)
I got it working.  I can still do the pictures if you want.

When you said it worked in house, that was the key.  I was using FireFox on my desktop to upload the certificate.  When I tried it from Safari on the mac it worked straight away.

So evidently your upload does not work with FireFox.

 

Gary,


To my knowledge we do not offer support offerings for individual incidents.  Can you please record your screen and upload it to youtube or a file-sharing host to explain what you're seeing as we cannot reproduce that in house.


Thanks,

Can we buy a support incident to get this resolved?

This is a test app that I am working on but out production app is also down with regard to pushes.

I am trying to use the test app to resolve the production problem.

 

 Hi,

I tried it a couple times.

I have attached one of the files.  This is for a test app.

The submit button always goes away and then it goes back to drag files here.  No error is displayed.

p12

Gary,


You need to export the certificate to a .p12 file and upload that.


Then hit the save button beneath.  


Thanks,

Login or Signup to post a comment